CA MOBILE エンジニアブログ

株式会社シーエー・モバイルのエンジニアブログです

【旧ブログ】にわっちのインフラ奮闘記vol4-社内用レイヤー2スイッチ設定

お久しぶりですヽ(=´▽`=)ノ
友達や同期が結婚していっているのを間近で見て、
最近ちょっと焦りぎみの にわっち( ゚д゚) ですww

さてさて、
今月1、2週目に、学生さん2名が、3日間のインターンに来てくれました。

お二人とも、インフラの領域に興味を抱いている学生さんでした。

課題

      D君

 

S君

    • LAMP環境構築
    • Ciscoスイッチ設定体験

今回のブログの内容はS君と一緒に行った レイヤー2スイッチ設定 です。
L3スイッチをL2スイッチとして設定しました。

■構成図

 

f:id:niwattitti:20150910160156p:plain

L2スイッチの主な設定内容

  • パスワード設定
  • VLANを3つ作成
  • EtherChannelを設定

■設定手順

ホスト名設定

SW>enable
SW#hostname niwatti

S君はまず、Cisco IOSのモードが3つあることを学んでいました。

ユーザーモードは、
基本的なモニタコマンドだけを使用できます。

特権モードは、
enableコマンドでユーザーモードから移行出来ます。
すべてのルータのコマンドにアクセスできます。

グローバルコンフィグレーションモードは、
configure terminalコマンドで特権モードから移行出来ます。
hostnameを変更したり、その他パスワード変更やinterfaceの設定等を行うことができます。

パスワード設定

niwatti#configure terminal
niwatti(config)#enable secret niwahoge

※configure terminalは設定モードに移行するコマンドです。
enable password  コマンドもあるのですが、この場合show running-configを行った際にパスワードが見えてしまいます。
enable secret のコマンドを使うことでshow running-config上ではパスワードは暗号化されます。
S君はコレに気づいてくれてenable secretコマンドでパスワードの設定をしてくれました。

Telnetパスワード設定

niwatti(config)#line vty 0 4
niwatti(config-line)#password niwahoge
niwatti(config-line)#login
niwatti(config-line)#exit
niwatti(config)#service password-encryption

service password-encryptionコマンドを実行することで、
show running-configで表示される設定ファイルのパスワードを暗号化しています。

VLAN作成(番号は任意)

niwatti(config)#interface Vlan30
niwatti(config-if)#no shutdown
niwatti(config-line)#exit
niwatti(config)#interface Vlan60
niwatti(config-if)#no shutdown
niwatti(config-line)#exit
niwatti(config)#interface Vlan90
niwatti(config-if)#ip address ?.?.90.? 255.255.255.0
niwatti(config-if)#no shutdown
niwatti(config-line)#exit

※no shutdownの設定を入れることでVLANを起動
no shutdown設定は割と忘れがちになってしまいますが、
この設定も事前に調べていたため、S君は入れてくれました。
それにしても、no shutdownで起動ってちょっと変な感じがしますよね、、、。

EtherChannelを設定
複数の物理ポートを単一の論理ポートに束ねる技術
ここでは、上記で作成したvlan 30,60,90を許可する設定にしています。

niwatti(config)#interface  Port-channel1
niwatti(config-if)#switchport trunk encapsulation dot1q
niwatti(config-if)#switchport trunk allowed vlan 30,60,90
niwatti(config-if)#switchport mode trunk
niwatti(config-line)#exit

ポートの設定

 

  • サーバーに接続される1-22まで

niwatti(config)#interface range GigabitEthernet1/0/1 - 8
niwatti(config-if)#switchport mode access
niwatti(config-if)#switchport access vlan 30
niwatti(config-lf)#exit
niwatti(config)#interface range GigabitEthernet1/0/9 - 14
niwatti(config-if)#switchport mode access
niwatti(config-if)#switchport access vlan 60
niwatti(config-lf)#exit
niwatti(config)#interface range GigabitEthernet1/0/15 - 22
niwatti(config-if)#switchport mode access
niwatti(config-if)#switchport access vlan 90
niwatti(config-lf)#exit

 
  • L3スイッチにLANで接続されている23,24

niwatti(config)#interface range GigabitEthernet1/0/23 - 24
niwatti(config-if)#switchport trunk encapsulation dot1q
niwatti(config-if)#switchport trunk allowed vlan 30,60,90
niwatti(config-if)#switchport mode trunk
niwatti(config-if)#channel-group 1 mode on
niwatti(config-lf)#exit

interface range GigabitEthernet を使うことで一度にまとめて設定することができます。
1つづつ行う場合は、 interface GigabitEthernet1/0/1 という風に記載します。
S君はまたもや調べていたため、最初から複数まとめて設定していました(驚き

※アクセスポートは,1つのVLANにしか所属できないが、
switchport mode trunkを指定することで、1個のポートに複数のVLANのデータを送ることができる。
また、channel-group 1 mode onを設定することで、
物理的な23,24のポートを単一の論理ポートに束ね、LANを冗長化しています。

デフォルトルート設定

niwatti(config)#ip routing
niwatti(config)#ip route 0.0.0.0 0.0.0.0 ?.?.90.?

※L3 スイッチのVlanのip addressを指定
L3スイッチをL2スイッチとして設定するときも、ip routing設定を行わないと、
ip route 0.0.0.0 0.0.0.0 ?.?.90.? の設定は有効になりません。

L3スイッチでip routingの設定を無効にしている場合(もしくはL2スイッチの場合)は、

niwatti(config)#default-gateway 0.0.0.0 0.0.0.0 ?.?.90.?

のコマンドでデフォルトルートの設定を行うことができます。
S君にはip routeの方で設定してもらいました。

設定の書き込み

niwatti#copy running-config startup-config

write memoryを以前は使うことが多かったみたいですが、
IOS10.3以降では copy running-config startup-config の方をciscoは推奨しているみたいです。

スイッチにtelnetして確認
最後に、Telnet してスイッチにアクセスし、ログイン確認を行った後、
利用している環境にpingを打って疎通確認をすれば完了です。

■スイッチを設定している様子

f:id:niwattitti:20150910160240j:plain

よく使ったコマンドとその省略コマンド
上記で出てきたものの説明は省きます。
enable           ⇒ en
configure terminal   ⇒ conf t
show running-config ⇒ sho run 現在の設定を確認する
terminal length 0 ⇒ ter len 0   sho runを入力したときにmoreが出ません
show interfaces ⇒ sho int インターフェイスの状態を表示する
show ip interface brief  ⇒ sho ip int b インターフェイスの状態をシンプルに表示する
show version ⇒ sho ver ルータの情報を表示する

■所感等

トレーナーとして、それぞれ3日間担当させていただいたのですが
最近の学生さんは、ともて優秀だなって思うと同時に、自分も負けられないなと思いました。

2人でスイッチ無事設定することができ、
そのスイッチが実際に社内のシステムに入って動いているのがとても嬉しく思いました。

また、スイッチの設定が非常に楽しかったので、
ネットワーク周りの知識もどんどん増やしていこうと思います。

それではまた近々。
今後とも にわっち をよろしくお願いします(`・ω・´)ゞ